IoTizar o ambientador Air Wick

BRUTAL :slight_smile:

1 Like

Bruno, tenho um Air Wick novo modelo, fiz usando um ESP01 e tasmota.

Boas,

Estou com uma dificuldade com este air wick. Está a funcionar, o meu problema é que tenho de dar um toque na roldana para funcionar.

O Air wick está a funcionar corretamente, com a minha automação necessito desse toque.

Não sei o que possa ter mal.

Não estaria a mandar menos corrente do que a necessária para a carga do motor?
Tenta medir o quanto de corrente é enviada pelo processo normal do aparelho e quanto é enviada pelo seu circuito.

Que componente é esse? Não me lembro de ver mosfets de 6 pinos. Partilha a referência para ver a datasheet a ver se é apropriado para esse fim.

Também podes experimentar soldar diretamente os fios em vez de meter esses conectores no meio.
As minhas experiencias com conectores dupont do ali quando é para meter alguma corrente (>100mA) não tem sido grande coisa, tem uma resistência de contacto elevada e tenho dificuldades a obter resultados coerentes, às vezes funciona muito bem, outras tenho de andar a meter e tirar até conseguir uma ligação de jeito.

A voltagem é de 3,065V, quando o motor é acionado tenho 0v enquanto com o Optoacopolador 4n25 passa 2,851v e não 0v.

O Optoacopolador 4n25 não devia funcionar como um switch?

E funciona, mas para pequenas correntes.
Onde é que o ligaste? Não mostras e não vi na descrição.
Se o usar para ligar diretamente o motor, é para esquecer, não vai aguentar. É melhor controlar o mosfet. Mostra foto da placa do ambientador onde ligaste os fios.

Não vejo também que tenhas usado resistência entre o ESP e o 4N25, é um risco.

Estou a usar as ligações identificadas pelo @IvoMarques

O comportamento não é bem o esperado, usando essas ligações o temporizador do air wick está sempre a funcionar, preferia ser eu a controlar o mesmo.

Não estou a usar nenhum resistência. Estava a usar o projeto inicial do bruno horta. Que reistência devo usar?

A foto não se percebe as ligações, e sem esquemas, não consigo ajudar.
O optoacoplador deve ligar do lado do controle e não do lado de potência. Não pode ligar diretamente ao motor, não está feito para essas correntes.

Um optoacoplador dentro é um LED e um fototransistor. Da mesma forma que não se deve ligar um LED diretamente a um micro, também não se deve fazer o mesmo num opto. Os GPIO do ESP8266 são de 3.3V, e corrente máxima de 12mA. Vf do 4N25 é de 1.5V, logo a resistência tem de ser maior que : (3.3V-1.5V)/12mA= 150 Ohms . Isto é o mínimo dos mínimos para respeitar as especificações do ESP, não faz mal nenhum dar uma margem, eu metia 220Ohm.

Boas. Não percebo nada de eletrónica mas vou fazendo algumas coisas quando a “receita” está bem explicada. Ou seja, sou daqueles que sigo um tutorial, passo a passo, e lá vou fazendo algumas coisas.
Neste caso pode-me explicar em que pin’s do Optoacopolador 4N25 é que liga os fios que vêm da placa do Air Wick e em que pin’s é que liga os fios vêm dos ESP8266? E já agora quais são os GPIO’s que está a usar no ESP8266? Obrigado.

Na placa do meu Air Wick já tenho estes fios soldados:

Pessoal. E se usar um Esp8266


Funciona na mesma? Aonde faço as ligações se quiser testar alimentando o esp8266 por usb?
Obrigado.

Viva Malta. O meu primeiro post no fórum. Vi que foram feitos alguns progressos em relação ao modelo novo do airwick, mas será que alguém podia partilhar imagens em relação aos pins tanto do 4N25 como do esp8266? Basicamente é a mesma pergunta do @nmota. Obrigado a todos

1 Like

Parece que ninguém vai responder!!! Tenho o projecto a meio!! :pensive:

IMG_20210520_184838

Viva malta.

Novo modelo do airwick.

Alguma ajuda onde devo soldar os fios de e para o 4N25?

Obrigado

Onde ligam os fios do motor?

@jm_araujo f31fb6ebe88701423d12c5edc2bfc03ace899d17

Hello. Alguém pode ajudar ?

Airwick%20anotado
Esta é a minha interpretação do circuito. Q3 é o Mosfet que liga o motor, R3 a resistência de pull-down da gate.
Se assim for, o 4n25 liga do positivo à gate. Positivo tens no terminal da pilha, gate no pino “interior” de R3.
Podes experimentar fazendo uma ligação direta entre esses dois pontos a ver se ativa o motor.

(não tenho nenhum dispositivo desses nem como validar a informação dou)

Viva!

Fiz ligação direta entre esses dois pontos que referiste (R3 e Q3) e não ativou o motor.
Fiz mais alguns testes e houve outras combinações que ativaram o motor, exemplo:

  • Q3 + C3
  • R3 + C3
  • R3 + C1
  • C2 + C3
    E mais algumas combinações que ativam o motor…

Alguma indicação onde posso fazer as soldas na placa do airwick ?

Obrigado